Index: [Article Count Order] [Thread]

Date:  Thu, 7 Dec 2006 14:32:22 -0800 (PST)
From:  Herb Rubin <herbr (at mark) pfinders.com>
Subject:  [coba-e:08131] Re: CGI scripts can't send mail
To:  coba-e (at mark) bluequartz.org
Message-Id:  <23383496.14431165530742466.JavaMail.root (at mark) z01.pfinders.com>
In-Reply-To:  <200612072150.kB7Lo5Dq016150 (at mark) bugs.northernweb.net>
X-Mail-Count: 08131

If you are using sendmail try using the -fyou (at mark) yourdomain.com along with the -t option

Herb

----- Original Message -----
From: Bill Berg <billberg (at mark) northernweb.net>
To: coba-e (at mark) bluequartz.org
Sent: Thursday, December 7, 2006 1:50:18 PM GMT-0800
Subject: [coba-e:08130] CGI scripts can't send mail

We recently coverted a Rqa550 to Centos/BQ.
Our CGI scripts aren't allowed to send mail. 
The scripts have correct permissions, although when you click "Submit" you
get the standard misconfiguration error. A closer inspection shows this
error
in the httpd/error_log:  malformed header from script

But the script does what it is supposed to do, up to the sending mail part,
it even tries to send the mail, we get this in the maillog:
Data format error, and it will not send the message. 
The mail is being sent from whoever@localhost,

Is there someplace to set the mail sender so that it goes through. This has
failed on Mattt Wright's FromMail.pl, and on a custom script we made with
PerlBuilder.

Bill Berg
Northern Webworks
715-627-0400 or 1-866-572-1333

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.432 / Virus Database: 268.15.15/579 - Release Date: 12/7/2006
1:31 PM
 




-- 
Herb Rubin
Pathfinders Software
http://www.pfinders.com