Index: [Article Count Order] [Thread]

Date:  Wed, 15 Dec 2004 18:18:27 +0000
From:  "Alexandre Abric" <alexabric (at mark) hotmail.com>
Subject:  [coba-e:01694] Re: PHP + Mysql (again ...)
To:  coba-e (at mark) bluequartz.org
Message-Id:  <BAY20-F306946F0035CA4453F8D20A4AD0 (at mark) phx.gbl>
In-Reply-To:  <200412151406.iBFE6cND019291 (at mark) ns.codacommerce.co.uk>
X-Mail-Count: 01694

I have all the RPMs connected to MySQL

mysql-bench-3.23.58-4
mysql-server-3.23.58-4
php-mysql-4.3.4-1.1
MySQL-3.23.54-1
MySQL-shared-3.23.54-1
perl-DBD-MySQL-2.9002-1
MySQL-client-3.23.54-1
MySQL-devel-3.23.54-1

I still get the error "Call to undefined function: mysql_connect() "

running : perl -e -MCPAN 'install DBD::mysql'
does nothing ... ! i'm not very familiar with perl

Now I remember how i managed to have php+Mysql working : i didn't use the 
reference ISO but the "standard" 3 CD's from redhat.com and selected the 
"php-mysql" package.

This is really upsetting ...

>From: "Leigh Blackwell" <leigh (at mark) codacommerce.com>
>To: "'Alexandre Abric'" <alexabric (at mark) hotmail.com>
>Subject: RE: [coba-e:01690] PHP + Mysql (again ...)
>Date: Wed, 15 Dec 2004 14:07:44 -0000
>
>What version of mysql are you using?
>Have you installed the libraries and client that are included in the mysql
>devel rpm? You wont be able to build a working DBD without them..(your 
>error
>suggests not)
>
>Best way of installing Cpan modules like DBD..
>
>perl -e -MCPAN 'install DBD::mysql'
>
>-----Original Message-----
>From: Alexandre Abric [mailto:alexabric (at mark) hotmail.com]
>Sent: 15 December 2004 13:17
>To: leigh (at mark) codacommerce.com
>Subject: RE: [coba-e:01690] PHP + Mysql (again ...)
>
>Yes, an absolute nightmare ... I also fixed that a few months ago and I
>can't remember how either.
>
>How do you install DBD:mysql ?
>I installed : perl-DBI-1.37-1.i386.rpm and perl-DBD-MySQL-2.9002-1.i386.rpm
>but there still must be something missing
>
>[root@www tmp]# perl -e 'use DBD::mysql; print DBD::mysql->VERSION'
>Can't load
>'/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/mys
>ql.so'
>for module DBD::mysql: /usr/lib/libmysqlclient.so.10: symbol errno, version
>GLIBC_2.0 not defined in file libc.so.6 with link time reference at
>/usr/lib/perl5/5.8.3/i386-linux-thread-multi/DynaLoader.pm line 229.
>at -e line 1
>Compilation failed in require at -e line 1.
>BEGIN failed--compilation aborted at -e line 1.
>
>Those are the perl rpms that I have :
>[root@www tmp]# rpm -qa | grep perl
>perl-GDTextUtil-0.86-0BQ1
>perl-GDGraph-1.43-0BQ1
>mod_perl-1.99_14-2BQ1
>perl-handler-utils-1.3.0-11BQ1
>perl-DBI-1.37-1
>perl-5.8.3-16
>perl-Filter-1.29-8
>perl-Data-Flow-0.09-0BQ1
>perl-Jcode-0.83-3BQ2
>perl-DBD-MySQL-2.9002-1
>perl-URI-1.21-7
>perl-GD-2.12-0BQ1
>perl-Quota-1.4.8-3BQ2
>
>By the way I uploaded my final webalizer PKG, it should give no error now.
>http://alexbidule.free.fr/bluequartz/webalizer.pkg
>
>Thx for your help :)
>
> >From: "Leigh Blackwell" <leigh (at mark) codacommerce.com>
> >To: <alexabric (at mark) hotmail.com>
> >Subject: RE: [coba-e:01690] PHP + Mysql (again ...)
> >Date: Wed, 15 Dec 2004 11:57:01 -0000
> >
> >
> >
> >This brings back a nightmare.... (cant remember how I fixed it)
> >
> >Do you have the file?
> >/etc/php.d/mysql.ini
> >
> >As I have disabled that one...
> >
> >My cce.ini file is as follows
> >
> >; Enable cce extension module
> >extension=cce.so
> >extension=mysql.so
> >include_path = "/usr/sausalito/ui/libPhp:/usr/sausalito/ui/web"
> >register_globals = On
> >
> >
> >
> >have you install DBD:mysql?
> >
> >perl -e 'use DBD::mysql; print DBD::mysql->VERSION'
> >2.1028
> >
> >This version is the most reliable with php (I believe) if you wish to use
> >it
> >with a v4 mysql I can let you know how to mod it.
> >
> >
> >
> >
> >-----Original Message-----
> >From: Alexandre Abric [mailto:alexabric (at mark) hotmail.com]
> >Sent: 15 December 2004 11:10
> >To: coba-e (at mark) bluequartz.org
> >Subject: [coba-e:01690] PHP + Mysql (again ...)
> >
> >I'm having problems getting working php+mysql together. I know this has
> >been
> >
> >discussed previously but I can't find any simple solution.
> >
> >I added in  /etc/php.d/cce.ini the lines :
> >extension=mysql.so
> >include_path = "/usr/sausalito/ui/libPhp:/usr/sausalito/ui/web:."
> >
> >I installed : php-mysql-4.3.4-1.1.i386.rpm
> >
> >And restarted apache
> >
> >But I still get the error in my php script : "Fatal error: Call to
> >undefined
> >
> >function: mysql_connect() in /home/.sites/28/site1/web/test.php on line 
>8"
> >
> >Could you explain what you did ? thx
> >
> > >From: "Leigh Blackwell" <leigh (at mark) codacommerce.com>
> > >Reply-To: coba-e (at mark) bluequartz.org
> > >To: <coba-e (at mark) bluequartz.org>
> > >Subject: [coba-e:01678] Stable?
> > >Date: Tue, 14 Dec 2004 15:11:23 -0000
> > >
> > >
> > >Hi All,
> > >
> > >It's got to the point that my cobalt lx50 based on FC1 and BQ is up and
> > >running without any issues and I have started to use it for hosting
> > >customer's sites. I see strings on here with ppl having issues with 
>fresh
> > >installations; fortunately I didn't really have any of these as I stuck
> >to
> > >the reference kit (not saying that other didn't :)
> > >
> > >I have done some work to try and make this machine a suitable 
>replacement
> > >for my leased xtr. Unfortunately I haven't taken notes on all the 
>issues
> > >that I have come across but I thought it would be good idea to cover a
> > >couple of points, and see if I indeed have a stable machine in the eyes
> >of
> > >others on the list.
> > >
> > >Split_log.patch
> > >Logrotate fixed
> > >Ssl_perl reference to port removed (restricted you to a single ssl site
> >per
> > >box)
> > >
> > >Removed cgi-bin directory and replaced it with /  in httpd.conf
> > >	Allowing cgi's to be executed in anywhere in the site (like the
> > >raq), 	I havent clarified if the site settings for CGI is working
> > >correctly.
> > >
> > >Ssl cgi (very bad hack) Added.. to the vhost file of site"**" to enable
> >cgi
> > >on ssl
> > >	AddHandler cgi-script .cgi
> > >	<Directory "/home/.sites/48/site**/web/">
> > >     	AllowOverride None
> > >     	Order allow,deny
> > >     	Allow from all
> > >     	Options +ExecCGI
> > >     	SSLOptions +StdEnvVars
> > >	</Directory>
> > >
> > >Changed httpd.conf
> > >DirectoryIndex index.cgi index.pl index.wml index.html index.htm
> > >
> > >In addition to the above fixes and mods, I have installed a couple of
> >extra
> > >things..
> > >
> > >Mysql 4.1.7
> > >Php-mysql on admserv
> > >Modified version of perl DBD-mysql 2.1028 (to over come connection
> >timeout
> > >issues with php and permit a v4 mysql)
> > >Mailscanner
> > >Mailwatch (v. good tool when integrated in gui)
> > >http://mailwatch.sourceforge.net/index.html
> > >ClamAV
> > >Webalizer
> > >Pkg, openwebmail
> > >Pkg, dev-tools
> > >
> > >
> > >I think my main worry is with apache and the small differences between
> >v1*
> > >and v2 which I believe are causing the ssl and cgi issues.
> > >
> > >I have seen talk of db versions 3 and 4 in relation to passwords etc, 
>but
> > >this is out of my depth and I am uncertain to whether this affects me, 
>if
> > >someone could advise???
> > >
> > >I haven't used any of the ruby project as I assumed that was for 
>redhat9
> > >installs.
> > >
> > >I really hope I have covered all the main fixes/mods (I'm not importing
> >any
> > >sites so I have left those issues out). Has anyone any suggestions on
> >ones
> > >that I should have in place?
> > >
> > >Hopefully we can see if we can get a definitive list for the next
> >release.
> > >
> > >Cheers
> > >
> > >LEigh
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> >
> >
> >
>
>