Index: [Article Count Order] [Thread]

Date:  Thu, 25 Nov 2004 03:05:33 -0600
From:  "Scott McClain" <smcclain (at mark) mcsgeek.com>
Subject:  [coba-e:01609] Re: not generating vsite ftp and mail logs
To:  <coba-e (at mark) bluequartz.org>
Message-Id:  <000d01c4d2cd$ec727830$d0b84441@vb183dmc51051>
In-Reply-To:  <20041123193906.C8669100A8 (at mark) smtp.bulldogdsl.com>
X-Mail-Count: 01609

Worked using:

 

/var/log/xferlog {

        missingok

        prerotate

                /usr/local/sbin/ftplog2commonlog < /var/log/xferlog | \

                        /usr/local/sbin/split_logs ftp

        endscript

        notifempty

        postrotate

                /usr/bin/kill -HUP `cat /var/run/proftpd.pid 2>/dev/null`
2>/dev/null || true

        endscript

}

 

Thanks.

 

-----Original Message-----
From: Leigh Blackwell [mailto:leigh (at mark) codacommerce.com] 
Sent: Tuesday, November 23, 2004 1:39 PM
To: coba-e (at mark) bluequartz.org
Subject: [coba-e:01603] Re: not generating vsite ftp and mail logs

 

 

On have seen the same issues. looking @ ftp first

 

On my XTR I have the following lines in /etc/logrotate.d/proftpd.

 

/var/log/xferlog {

        missingok

        prerotate

                /usr/local/sbin/ftplog2commonlog < /var/log/xferlog | \

                        /usr/local/sbin/split_logs ftp

        endscript

        daily

    # ftpd doesn't handle SIGHUP properly

    nocompress

}

 

Compared to standard bq /etc/logrotate.d/proftpd.

 

/var/log/xferlog {

        missingok

        notifempty

        postrotate

                /usr/bin/kill -HUP `cat /var/run/proftpd.pid 2>/dev/null`
2>/dev/null || true

        endscript

}

 

 

 

I would start with a mix of the to as /usr/local/sbin/ftplog2commonlog
exists

 

/var/log/xferlog {

        missingok

        prerotate

                /usr/local/sbin/ftplog2commonlog < /var/log/xferlog | \

                        /usr/local/sbin/split_logs ftp

        endscript

        notifempty

        postrotate

                /usr/bin/kill -HUP `cat /var/run/proftpd.pid 2>/dev/null`
2>/dev/null || true

        endscript

}

 

 

I don't have any ftp traffic to test this on :-)

 

Let me know..

 

Cheers

 

Leigh

  _____  

From: Scott McClain [mailto:smcclain (at mark) mcsgeek.com] 
Sent: 23 November 2004 16:22
To: coba-e (at mark) bluequartz.org
Subject: [coba-e:01600] not generating vsite ftp and mail logs

 

I recently noticed that in each vsite "logs" directory my ftp.log and
mail.log files are not being generated.  Although web.log is working fine.
Here is a listing of one of my vsites logs directory.  All other vsites are
consistent with this problem.

 

 

[root@mcsserver logs]# ll

total 380

drwxr-xr-x  5 SITE2-logs site2   4096 Nov 17 16:32 2004

-rw-rw----  1 SITE2-logs site2    344 Jul  9 22:49 ftp.daily

-rw-rw-r--  1 SITE2-logs site2  26971 Nov 23 10:10 ftp.stats

-rw-rw----  1 SITE2-logs site2   1176 Nov 23 10:11 mail.daily

-rw-rw-r--  1 SITE2-logs site2  44261 Nov 23 10:11 mail.stats

-rw-rw----  1 SITE2-logs site2  36760 Nov 23 09:22 web.daily

-rw-rw----  1 SITE2-logs site2  89245 Nov 23 04:02 web.log

-rw-rw----  1 SITE2-logs site2     30 Nov 22 16:34 web.log.1.gz

-rw-rw----  1 SITE2-logs site2     30 Nov 22 16:27 web.log.2.gz

-rw-rw----  1 SITE2-logs site2   2010 Nov 22 04:02 web.log.3.gz

-rw-rw----  1 SITE2-logs site2  40742 Nov 21 04:02 web.log.4.gz

-rw-rw-r--  1 SITE2-logs site2 112525 Nov 23 09:22 web.stats


	

1609_2.html (attatchment)