Index: [Article Count Order] [Thread]

Date:  Mon, 27 Sep 2004 14:18:20 +0400
From:  Dmitry Alexeyev <dmitry (at mark) cobaltsupport.com>
Subject:  [coba-e:01236] Re: cced crash
To:  coba-e (at mark) bluequartz.org
Message-Id:  <200409271418.20253.dmitry (at mark) cobaltsupport.com>
In-Reply-To:  <20040927095101.10277f3f@localhost>
References:  <200409261458.19847.dmitry (at mark) cobaltsupport.com> <20040927095101.10277f3f (at mark) localhost>
X-Mail-Count: 01236

On Monday 27 September 2004 05:51, patricko wrote:
> Hi,
>
> I dont know whether FC2 - SE Linux and CCE - ACL
> will work well. Apparently, both are internal firewalls.
>
> Anyway. Did you put in the CCE schema and disable FC2 - SE Linux?
>

I have commented out this value in schema and got cced (almost) working. 
At least no segfault anymore.

I really doubt SE Linux is the reason of segfault on ghash_iter_first 
(). I will do some debugging later, I suspect there's some logic error 
in ghash building. It's a pity cced doesn't let the user know what's 
really happening with it. 

I have some problems with ui. E.g. it doesn't know property 
"isLicenseAccepted". I don't know if it is my setup problem or ui in 
general. I also see lots of PHP warnings in error_log. 
Wizard changes admin password incorrectly: it puts '/' as root hashed 
password into /etc/shadow and hash without salt for admin (skips 
$XXXXXX$XXX$ - not sure about number of characters here, Suspect it 
just puts '$' unescaped?). 
All those problems require futher investigation. 

Some quick notes on cced: all tests fail expecting version of cced 
0.80.1 and not 0.80.2 - that requires update. Also all tests do not 
expect line "client [<PID>] has admin rights" - perhaps this requries 
test suite rewrite?
cced source rpm misses build dependencies on flex, bison and gettext.

Anyways, I've got FC2 working in user-mode-linux and most of cced and 
gui in it. 
If somebody wants my notes published (I mean FC2 installation in 
user-mode-linux) - please let me know. That's from scratch type of 
installation without using installer, etc. Pretty useful for 
development, especially when using Copy-On-Write for filesystem images: 
return to initial state takes only a couple of minutes.
That'd be great if someone could help me to "polish" these notes. 

BTW, biggest FC2 problem I've found is broken rpm which sometimes fails 
to create dirs during cpio restoring or just says "lsetfilecon failed". 
Quick search in google didn't show any solutions, which is strange to me 
- I used to get this error on every 5th rpm I installed. I've built rpm 
from fedora-development (FC3 test2 or even newer), it seems to have 
solved the problem.

WBR
Dmitry
>
> Cheers
> Patrick
>
> On Sun, 26 Sep 2004 14:58:19 +0400
>
> Dmitry Alexeyev <dmitry (at mark) cobaltsupport.com> wrote:
> > Sep 26 06:42:37 localhost cced(smd)[1574]: Invalid type
> > "userNameGenMode" for "Vsite.UserDefaults.userNameGenMode"
> > Sep 26 06:42:37 localhost cced(smd)[1574]: Removing class "Vsite",
> > namespace "UserDefaults"